Forum Discussion

Hiphubby123's avatar
Hiphubby123
New Contributor III
6 months ago

Cox Remote Battery Life

I replaced the batteries in my Cox Cable remote but the onscreen battery life indicator still shows a low percentage of 31%.  Isn’t the percentage supposed to update to show 100% after you put new batteries in the remote?

  • I did check the batteries and they were good.  However, I decided to change them again and the next set of batteries worked.  The onscreen battery strength indicator now shows 100%.  Odd, but the batteries that did not seem to work were Energizer and the ones that did work are Duracell.  Maybe the remote prefers Duracell.  No, I doubt that has anything to do with it but it was strange.  Problem solved.

3 Replies

Replies have been turned off for this discussion
  • Darkatt's avatar
    Darkatt
    Honored Contributor

    Sometimes new batteries do not have a full charge., They may have been sitting for a long time. I use rechargeable lithium batteries, they always work well, and hold a charge for a long time, and easily outlast alkaline batteries. 

  • lhn_fan's avatar
    lhn_fan
    New Contributor III

    I always have seen 100% after changing remote batteries.

    I'd check the age of the new batteries first.  You could also make sure that the connections are good and that the batteries are installed in the proper orientation.  If those check out I'd try different batteries to be sure you don't have some bad ones.  If you have a multimeter you can check the voltage of the old and new batteries.

    However, if the remote is operating normally it probably doensn't matter.

     

  • Hiphubby123's avatar
    Hiphubby123
    New Contributor III

    I did check the batteries and they were good.  However, I decided to change them again and the next set of batteries worked.  The onscreen battery strength indicator now shows 100%.  Odd, but the batteries that did not seem to work were Energizer and the ones that did work are Duracell.  Maybe the remote prefers Duracell.  No, I doubt that has anything to do with it but it was strange.  Problem solved.